Thread Number: 8075
Hoover Model 61
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 89839   1/23/2010 at 21:07 (3,549 days old) by schwinnapproved ()        

Picked one up today at a resale shop. Needs quite a bit of TLC. Motor runs but needs some bearing work. The bristle strips on the brush roll are GONE. Someone re-painted the base at some point so its a lighter than normal shade of brown. The switch and cord also need some work.

I currently have the motor apart (waiting for the PB to kick in so I can try and pull the fan). The carbons are still good but the motor is thilthy. The top (sleeve bearing) is still good, just needs a cleanup and good oil job.

I'll post updates and possibly pictures when I can.

If anyone by chance has a set of bristle strips for this model that your willing to part with I'd gladly buy them. I'm heading back to my apartment tonight (at my moms now) so I won't have internet. I do have email acess on my BlackBerry though so, in regard to the bristle strips you can contact me at the e-mail address posted on my profile.

Thanks





Post# 89867 , Reply# 1   1/23/2010 at 23:44 (3,549 days old) by schwinnapproved ()        

Just got it all back together. Runs really nice now! Both bearings have been refurbished and while the armature was out I went ahead and resurfaced the commutator. All thats left now is mostly cosmetic work and the brush strips for the brush roll.

Also a special thanks to Corey for the "handy sac" bags to go with it.

here is a picture of it back together.


Post# 89868 , Reply# 2   1/23/2010 at 23:45 (3,549 days old) by schwinnapproved ()        

Heres one with it running.

Post# 89889 , Reply# 3   1/24/2010 at 05:54 (3,549 days old) by kenmore81 (Warwick, RI)        
Very nice Matt

kenmore81's profile picture
I miss mine.I can't remeber the model # but mine had the square hanle =) Good luck with it,it looks great.
Kenny


Post# 89920 , Reply# 4   1/24/2010 at 14:03 (3,549 days old) by gottahaveahoove (Pittston, Pennsylvania, 18640)        
FAB !!!!!!

gottahaveahoove's profile picture
I have one too. It's needs attention. Got in Pgiladelphia. motor is frozen. I hope to get it running, as it was "The finest cleaner ever built".It deserves some care... don't we all? lol

Post# 89922 , Reply# 5   1/24/2010 at 14:10 (3,549 days old) by electroluxxxx (Syracuse, NY )        

electroluxxxx's profile picture
well john
I told you that I would get it going when you had the minimeet as I am thinking about bringing the tool bag with me. lol :)


Post# 89985 , Reply# 6   1/25/2010 at 10:24 (3,548 days old) by jmm63 (Denville, NJ)        

Funny, my 61 looks exactly like yours, including scuffs, scrapes and bad paint job. It was my Grandmothers and still in use at my Mom's house in Michigan. Next time I'm home I'll either bring it back with me or at least take a picture.




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy