Thread Number: 43822  /  Tag: Brand New Vacuum Cleaners
Am I changing this belt correctly? (Pictures)
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 457181   10/1/2022 at 20:47 by mark40511 (Lexington, KY)        

mark40511's profile picture
Hey guys...I'm almost embarrassed to ask such a question on here about changing a belt....Here's the thing...It's been about a year and I decided to take the brush roll out...vacuum around down there and while I was there I changed the belt...used the vacuum for a week... everything seemed fine...then I hear this squeaking sound when pulling the vacuum back and sometimes pushing forward...this is on low pile berber....So I put another belt in and the sound went away (but for how long?) Am I doing something wrong? Can someone look at these pics...I hope they are clear enough... I'm not sure what that metal piece is that sticks out sort of in the middle that the belt almost touches....what exactly is that? The belt replacement instructions in the manual aren't very clear....Possibly I did it right but just had a bad belt? I didn't hear it slipping though...just more of a squeak...especially if I went over an area rug...thanks

This is a cirrus CR79 about 4 years old


  Photos...       <              >      Photo 1 of 2         View Full Size
Post# 457186 , Reply# 1   10/2/2022 at 10:46 by Centralvacs1928 (Oak Brook, IL)        

centralvacs1928's profile picture
Looks right to me.

If the squeaking happens when pushing/pulling only (not continuously) I would suspect wheels rather than brushroll. A drop of lubricant like Tri-Flow on each wheel at the axle should make it go away.

Hope this helps,

Owen


Post# 457195 , Reply# 2   10/2/2022 at 17:10 by mark40511 (Lexington, KY)        

mark40511's profile picture
Thanks I think the main reason I was wondering if I had it on correctly is after vacuuming then opening the bottom to check to see if things looked ok...the belt had slightly moved in this direction.. I put arrows showing...the bottom arrow the side of the belt was touching that.

  Photos...       <              >      Photo 1 of 2         View Full Size
Post# 457201 , Reply# 3   10/2/2022 at 21:48 by huskyvacs (Indiana)        

huskyvacs's profile picture
The belt squeaking will happen with old belts that have been rotting in the package, the rubber has oxidized and that is being burned off by friction as you use it, it might squeal some until that layer wears off. CRC makes a belt conditioning product for car belts, you can spay some on a rag and rub the belt down and after a few treatments a week or so apart it should rejuvenate the belt.

That metal bar seems to be a guide to stop side-slip on the belt so it doesn't fall off the pulley. The belt can not fall off with that guide bar in place. The belt will go back in line once the vacuum is running and under tension.


Post# 457202 , Reply# 4   10/2/2022 at 22:43 by mark40511 (Lexington, KY)        

mark40511's profile picture
Ahhh.. gotcha...I guess I was puzzled because I didn't think that the belt rubbing against something could be a good thing.

Post# 457374 , Reply# 5   10/11/2022 at 17:46 by mark40511 (Lexington, KY)        

mark40511's profile picture
I just ordered a pack of five belts on amazon. I didn't go with the Cirrus brand this time because I don't wanna deal with this again. The squeaking gets worse and worse.....Belt is on correctly...but after USING the vacuum...I pop the bottom off only to find that the belt is almost off the pully, completely rubbing up against that guard or whatever that is...No wonder it was squeaking...It literally wouldn't stay in place the way it was supposed to.. I think it was totally stretched out too far ....

so I got the other belt out of the package and that seems to be OK... I ran the vacuum and after vacuuming the entire house...the belt actually stayed in place and wasn't rubbing up against anything....

In all of the years I've had vacuums... I've RARELY ever had to change a belt...UNTIL this Cirrus vacuum... Even my Rainbow (2006) I think I've only changed the belt once and it still purrs along and even when I changed it it wasn't slipping or anything...It had just been so long that I figured I should change it.

I like this Cirrus but the company Essco must not make very good belts...OR I guess it could be that they are just so old... What does a person have to do to get a decent belt?


Post# 457386 , Reply# 6   10/12/2022 at 14:01 by mark40511 (Lexington, KY)        

mark40511's profile picture
I received 5 new belts and OH MY GOD what a difference... I was sure this last belt wasn't stretched because it was not slipping... that's why I was so confused.. I expect the first sign of a bad belt would be slipping...not squeaking. It was spinning perfectly while vacuuming but the belt must have been stretched just enough to spin the brush fine, while simultaneously not able to stay in place on the pully....this new belt fixed all that...




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy