Thread Number: 40842  /  Tag: 50s/60s/70s Vacuum Cleaners
Worn out hose end causing attachment slippage
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 433907   10/21/2020 at 18:33 by Kirbyrama (Pennsylvania)        

I have a problem with the metal tube end of an older Kirby hose. Attachments and extension tubes slip off too easily when in use and does not grip well. In other words , the tube end is too smooth to hold any attachment for too long before they slide off. Rather than ordering a replacement end; what could be done to remedy this problem? In the past, I tried roughing the end of the tube with emery paper. The grip did not last long.




Post# 433909 , Reply# 1   10/21/2020 at 19:25 by huskyvacs (Indiana)        

huskyvacs's profile picture
It's not the metal hose end at fault but the attachments. Plastic bends and warps over time and with use and they just gradually bent more and more outward until they do not fit.

Easiest fix would be to wrap clear rough medical gauze tape around the end of the hose as much is needed until the tools hold firm. Another idea to try is that you might be able to carefully get the plastic hot on the attachments with a hair dryer on high heat and with a mitt gently and evenly squeeze the neck of the attachment tool in small hold and release squeezes, gradually tightening up the connecting end of the tools, and then check the fitment to the hose to see if it has improved. I did this with Electrolux crevice tools that had gotten crushed or loose to connect and it worked, but those might be a softer plastic material.


Post# 433917 , Reply# 2   10/21/2020 at 21:38 by johnnyb59c (13240 n 3980 rd dewey oklahoma)        
what model?

johnnyb59c's profile picture
I have tons of attachments that fit perfectly

Post# 433945 , Reply# 3   10/22/2020 at 05:31 by Kirbyrama (Pennsylvania)        

This is for a 519 model. The hose end is not the original.

Post# 433973 , Reply# 4   10/22/2020 at 17:22 by johnnyb59c (13240 n 3980 rd dewey oklahoma)        
not original?

johnnyb59c's profile picture
how so?

Post# 433993 , Reply# 5   10/22/2020 at 22:46 by Kirbyrama (Pennsylvania)        

The swivel tube end had been replaced perhaps 15 years ago.

Post# 434162 , Reply# 6   10/25/2020 at 01:51 by Kirbyrama (Pennsylvania)        

So far, that special tape is working. The attachments and extension tubes fit firmly and do not slip off easily.

Post# 434189 , Reply# 7   10/25/2020 at 16:54 by johnnyb59c (13240 n 3980 rd dewey oklahoma)        
ok

johnnyb59c's profile picture
cool




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy