Thread Number: 38666  /  Tag: 80s/90s Vacuum Cleaners
Electrolux Model 1521 powerwand runs even when the vacuum is off
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 410916   6/26/2019 at 16:59 by semiret (Coos Bay, OR)        

New member here. I have an Electrolux Model 1521 vacuum that we bought new back when I had hair.

It has run flawlessly up until about a month ago. Here's what happened:
- With the vacuum plugged in, but the switch turned off, the powerhead would run. It had never done this before
- When the vacuum was switched on, the powerhead would continue to run, (like it was supposed to)
- The same day, the vacuum quit working altogether.

Took the vacuum down to a local repair man, who replaced the vacuum motor.

The vacuum now works fine, but I am still having issues with the powerhead.

I am thinking this is a wiring issue that happened just before the vacuum motor burned out. I am hoping this issue didn't cause the motor burnout.

I am rather handy, but have no wiring information so am hesitant to dig too far

I need some help troubleshooting this.

Thank you in advance





Post# 410925 , Reply# 1   6/26/2019 at 22:35 by MadMan (Chicago, IL, USA)        

madman's profile picture
Possibly the switch?

Post# 410927 , Reply# 2   6/26/2019 at 23:01 by compactc9guy (Bathurst NB)        

compactc9guy's profile picture
Wires cross inside possibly

Post# 410929 , Reply# 3   6/26/2019 at 23:28 by vacuumlad1650 (Chicago Suburbs)        

vacuumlad1650's profile picture
Wiring was mixed up so now the power nozzle leads are connected to power, without running through the switch


Post# 410934 , Reply# 4   6/27/2019 at 09:01 by Paul (USA)        

Welcome to Vacuumland.

The Electrolux Corporation model 1521 was changed and upgraded over a decade—from the mid-1980s to the early-1990s. When these occurred the company used different colors and/or model names to identify them. Different models of power nozzles were used, too.

If you don't know the model name of yours and want more info., post some photos of it and the power nozzle on this thread.

Btw, the specs of the tank (main motor unit) are on the inside cover of the bag door, and the power nozzle's specs are on the bottom. The serial number is on the tank's stabilizer (5-digit production number in between a 2-letter series).

Electrolux Corporation is now called Aerus LLC, so if you have an Aerus store in your area you may be able to get some NOS parts for it such as a replacement switch or brush roll; although aftermarkets are available, too.


Post# 410940 , Reply# 5   6/27/2019 at 10:14 by Dysonman1 (Missouri Ozarks)        

dysonman1's profile picture
At some point the two top wires that connect to the cord winder were reversed in position. I have accidentally done this when repairing machines. You only have to switch the position of the top two leads and all will work correctly.

Post# 410941 , Reply# 6   6/27/2019 at 10:23 by semiret (Coos Bay, OR)        

Thank you all. I've added a couple pictures that hopefully will help identify what I have.

On the inside of the bag cover, it says:
- Vacuum cleaner
- Model 1521

On the bottom of the power nozzle, it says:
- POWER NOZZLE
- MODEL 1692

The serial number on the tank stabilizer (the front wheel?) is M02223G

One other thing. I was not very clear about what happened. I'll try again
- We were vacuuming as normal. Vacuum was ON and the power nozzle was ON
- Turned the vacuum cleaner OFF, and the power nozzle stayed running
- We then unplugged the vacuum from the wall
- When we went to run just vacuum (power nozzle not connected), the vacuum motor would start and stop. Within an hour of acting like this, the motor quit altogether.

So I believe the problem with the power nozzle has something to do with wiring or a switch. However, this cause happened on its own. Before anyone was inside it.

I have tried following the wiring with an ohm meter to maybe get a clue to where the problem is, but since I don't know what is normal, I don't have much confidence.

Sooooo, I came to the brain trust.

Thank You


  Photos...       <              >      Photo 1 of 2         View Full Size
Post# 410942 , Reply# 7   6/27/2019 at 11:03 by semiret (Coos Bay, OR)        

Sorry - I'm a new member can can only post a message once within 30 minutes.

Dysonman1 - I was typing my response at the same time you were adding your suggestion, so you did not know that the problem happened before anyone was inside. However, I tried swapping the leads as suggested anuway, but no luck. So I returned the leads to their original positions

I've added a picture of the cord reel to show the leads. This is the way they were originally and the way they currently are

Thank you very much for the suggestion. I would not have known to try that or what happens when this is done. I will chalk this up to my education

Steve


  View Full Size
Post# 410944 , Reply# 8   6/27/2019 at 12:07 by kirbylux77 (Orillia, Ontario, Canada)        

kirbylux77's profile picture
Steve - Question for you. Has anyone ever opened up the bag door?

You say this vacuum was running fine up until a month ago. On your Electrolux UltraLux, these metal tanks made from 1968 to 1994 had only four places where the wiring & connections were made: The bag door, power switch, motor & cord reel. The majority of the connections are made directly inside the bag door. At the bottom, there is a wiring harness with three wires that leads to the switch, motor & cord reel to make the rest of the connections. The switch & motor connections only have 2 wires on them, so impossible to mess those up. If you already tried swapping the cord reel wires, that leaves only one possibility - the bag door connections.

When you open the bag door to change the bag, you will see a plastic pole that contacts the cardboard bag collar when you close the bag door. If you take the plastic cover off on the inside of the bag door, you will see that pole activates a contact switch with three wires connected to it. This is part of the Automatic Control system which shuts the vacuum off when there is a full bag, if that pole isn't depressed by a bag being in place the vacuum will not run. There are also a few wires connected to the metal hose connector on the bag door. This has the contacts inside that make contact with the 2 metal prongs on the hose connector which power the hose, wand & powerhead.

What I am willing to bet is that someone, at some point in time, opened up the bag door & tried to repair the vacuum, & when they put it back together they put the wires in the wrong connections. Take your ohm meter & check all the connections inside the bag door. It might also be a good idea if you can find another metal canister & look to see exactly how it is wired inside the bag door. The Diamond Jubilee, Marquise, Grand Marquise & metal UltraLux canisters are all virtually identical inside with respect to their wiring & layout, so any of those will do.

Hope this helps you out & you can get your Electrolux canister back working normally & cleaning your home.

Rob


Post# 410945 , Reply# 9   6/27/2019 at 12:22 by semiret (Coos Bay, OR)        

I thought I would use Dysonman1's suggestion and go a step farther.

I checked the continuity between the plug and the connections on the cord winder.

My knowledge of AC current has some holes in it, so please don't laugh too hard.

- I tested the wall outlet with a voltage detector (Greenlee GT-11). I have voltage at the little plug and none at the big plug. So, I would think that the big plug would be the common wire
- I then tested continuity of the cord winder.
- I have continuity between the small spade on the plug and the white wire.
- I have continuity between the large spade and the black wire.

Although swapping these wires on the cord winder did not solve my problem, it seems to me that the continuity test was backwards.

Shouldn't the small spade be connected with the black wire and the large spade connected with the white??

If so, I will go ahead and swap these wires.

However, I need some help on my next step

Oh, BTW, I have an Aerus dealer in Eugene, about 100 miles away. I called them yesterday morning. No one was there, so I left a message. No answer yet

Thanks
Steve


Post# 410946 , Reply# 10   6/27/2019 at 13:00 by semiret (Coos Bay, OR)        

Kirbylux77

Except for when the motor was replaced last week, the last person in the machine was an Aerus repairman in Salt Lake City. We would take the machine there once a year for a maintenance checkup. It has run fine until now

I opened up the bag door - picture included

I have continuity between the white wire on the cord winder and the white wire on the hose connector. This connects on the right side

I have continuity between the black wire on the cord winder and the black wire on the hose connector. This connects on the left side

This continuity exists whether the bag door is open or closed. It also exists whether the vacuum switch is on or off

Is this continuity with the black wire correct? Doesn't sound like it should be

Steve


  View Full Size
Post# 410947 , Reply# 11   6/27/2019 at 14:13 by human (Pines of Carolina)        

human's profile picture
I had a similar problem with a slightly older Electrolux Silverado, which came to me as a basket case last fall and I resurrected from the dead last spring. In taking it apart, I disconnected the wires on the cord winder and reconnected them in what I thought was a logical manner with the two white wires on the double connector and the black wire by itself on the single connector. This appears to be how yours is wired in reply #7 above.

With it wired that way, the power nozzle wouldn't run when the vacuum was turned on but would run when the vacuum was turned off. By swapping one of the white wires to the single terminal and the black wire to the top of the double terminal, everything worked fine. Try that and if it doesn't work right, then swap the two white wires and see if that does the trick.

I've included a link below to the thread I created to document my trials and tribulations with the Silverado. In reply #7 of that thread, there is a link to a site that shows a teardown of a Diamond J, which is the next model older than yours and the next model newer than mine. As someone else has already mentioned, it's nearly identical to yours. The photo of the wires on the cord winder in that tutorial is incorrect as evidenced by the numbers on terminals and the wires. Wires 2 and 3 are clearly on the wrong terminals. This is what threw me when I wired mine up initially because I focused on the colors and not the numbers.


CLICK HERE TO GO TO human's LINK


Post# 410949 , Reply# 12   6/27/2019 at 16:27 by semiret (Coos Bay, OR)        

Human - Thanks for that link. I read it with great interest.

I hesitate disconnecting the double white wire connection because they are very tight and appear to have been that way for ever. I looked at the colors very carefully, and I don't think either is grey. One might be a very light brown

also, this problem with the power nozzle just recently started, all by itself. No one had been in there. The motor was replaced shortly afterward, but it was after this problem with the power nozzle started

Upon further experimentation, I found out that the power nozzle will even run with the bag door open!!!

Does anyone have a wiring diagram??? The closest I have found is a diagram for a 2100 which shows a yellow wire going from the cord winder to the hose.


Post# 410952 , Reply# 13   6/27/2019 at 19:15 by semiret (Coos Bay, OR)        

I just finished an experiment.

I
- Unplugged the power nozzle from the hose
- Plugged in the vacuum, but did not turn it on
- Checked for voltage across the power nozzle connector in the hose
- I got 120 volts

My question - should I have 120 volts with the vacuum turned off??

I've attached a picture because I know I am not describing this well

Thank You
Steve


  View Full Size
Post# 410955 , Reply# 14   6/27/2019 at 21:30 by human (Pines of Carolina)        

human's profile picture
No, you should definitely not have 120v at the hose handle when the machine is turned off. You've got a dead short somewhere.

Post# 410971 , Reply# 15   6/28/2019 at 08:55 by semiret (Coos Bay, OR)        

Even through this problem with the power nozzle started before anyone was into the machine, the more I learn from everyone here, the more I am beginning to think that this must be a wiring issue.

I have not seen any burnt connection or crossed wires or anything else that might have happened on it's own to account for what I have been finding.

So, it looks like I have two ways I can go
1) Disassemble the machine and draw up a wiring diagram for the way it is today. I will follow that link Human provided. That machine looks just like mine, with the exception of mine does not have the vacuum line on the cord winder. Hopefully by posting that diagram, someone could see what the problem is. Such a diagram would also be of help for others.
2) Change the wiring at the cord winder. I currently have 2 white wires on the incoming current side (small spade on the plug) and 1 black wire on the common side (large spade on the plug). The 2 white wires are connected very tightly and I did not want to try to take the apart too aggressively. The machine does work now and would hate to bust the connection

On further thought, I think I'll try taking apart the 2 white wires first. That would be the fastest experiment. If that does not work, then I can do the disassembly.

Thank you

Steve


Post# 410980 , Reply# 16   6/28/2019 at 15:41 by semiret (Coos Bay, OR)        

Good Afternoon.

Here's a status:
- I separated the two white wires (one is actually kind of a yellowish light green. Connected the black wire and white wire together to one of the cord winder connections. Connected the yellowish light green wire to the other.
Result was the power nozzle did not work. Tried swapping the connections on the cord winder, but still no luck
- so I took apart the machine and have come up with a wiring diagram. This is as it was before I tried moving things around.

One thing that jumped out at me was the black wire went directly to one side of the hose, the white wire went directly to the other. No wonder it always ran

I cannot fathom how this happened!!! Someone, somewhere HAD to have been messing around

The diagram is as the machine was when I started. The only change I have made is I swapped the black & light green wire at the cord winder.

I need some help.

Thanks
steve


  View Full Size
Post# 411018 , Reply# 17   6/29/2019 at 14:32 by semiret (Coos Bay, OR)        

OK - I need to talk a little electrical theory here.

Using the wiring diagram above, I tried the following combinations of wires at the hose winder

Terminal 1 Terminal 2 Vacuum Nozzle
- light green white did not run ran with on/off switch
- light green black ran did not run
- black/white light green ran did not run
- white/light green black ran always ran even with vacuum off

I did not try black/light green on term 1 with white on term 2 because the white wire is the one with the double connector

Also, these results were the same regardless of which terminal they were on

judging by the diagram, I would have thought that test 3 (black/white on term 1; light green on term 2) would have worked because of this thinking

- with nozzle off, current would flow thru green wire to motor, thru grey wire tho switch, thru red wire to bag door switch, thru black wire to cord
- with nozzle on, current would flow the same path with the addition of flowing thru the white wire to the cord.

I am absolutely positive that no-one has been messing with any connections within the vacuum

I am at a lose with what to do and will sleep on it. sometimes I get some new ideas in my sleep.

In the meantime, does anyone have any suggestions on what I should try next//

Sorry for the long post

Steve


Post# 411048 , Reply# 18   6/30/2019 at 10:29 by Dysonman1 (Missouri Ozarks)        

dysonman1's profile picture
Have you hooked the two motor wires to power to check and make sure the canister motor actually runs?

Post# 411051 , Reply# 19   6/30/2019 at 13:18 by semiret (Coos Bay, OR)        

I have not tried connecting the canister motor directly to power, but the vacuum does suck (maybe not the best term, but it does pick up dirt), so I will say the motor does run.

Here is what I am trying to determine
- The bag door switch has three wires (red, white and blue)
- The red wire connects to the on/off switch
- The white wire connects to the bag door open light. The other wire coming out of the light is black, which connects to the left side of the hose
- The blue wire connects to the left side of the hose. This is the same connection as the black wire from the light & the black wire from the cord winder

- The red & white wires have a direct connection. They are connected to a common bar, so always have continuity
- The red & blue wires have a connection only when the bag door is closed. When it is open, then the connection is broken

-
- I have multiple questions, but here's my first:
If the red & white wires have a constant connection, how come the light does not light when the bag door is closed?

- Question 2 (Related to Q1 and probably more inportant):
Explaination for Q2: When I look at the wiring diagram, it seems to me that connecting the black & white wires together should be the correct config.. However, when I do that, the power nozzle does not work at all. It's almost like the current continues to follow the black wire on the left side of the hose instead of following the white wire on the right.
Q2: If the current has multiple paths it can follow, what determines which path?

Thank you

Steve

PS - Sorry about the chart on my prior post. I was not able to update it so I have reproduced it here

These are tests of various connections to the cord winder

Terminal 1.................Terminal 2.......Vacuum.............Nozzle
light green................white............did not run .......ran with on/off switch
light green................black............ran................did not run
black/white................light green......ran................did not run
white/light green..........black............ran................always ran even with vacuum off

These results were the same even if the wires were reversed


Post# 411056 , Reply# 20   6/30/2019 at 15:09 by semiret (Coos Bay, OR)        

In doing some research, I think I have answered my first question.

In the bag door switch when the door is closed, electricity flow between the red & blue wire as well as the red & white wire. However, the light does not light up because there must be enough resistance in the white wire (or bulb itself) that will prevent enough electricity to pass to light up the light. When the door is opened, the connection between the red & blue wire is broken, which causes all the electricity to flow between the red & white wire, thus the light lights up.

So, expanding upon this, I wonder if my problem is I have increased resistance somewhere in the hose circuit that prevents enough electricity to flow thru to operate the power nozzle thru the normal circuit that includes the on/off switch. This might also explain the motor burning out at the same time this problem started.

Working theory - now what to do about it :)

Steve


Post# 411082 , Reply# 21   7/1/2019 at 18:07 by semiret (Coos Bay, OR)        

Took the vacuum down to the local repair shop - not authorized electrolux, but he's been in business for 40 years. No luck. Insisted that my power nozzle hose must have had it's own on/off switch. It never did

So, I just bought a good looking Ultralux Classic, identical to the one I have, off eBay.

Will be here between 7/8 & 7/16.

Hopefully I will be able to use that one to help find out what happened. I'll also have some spare parts. Probably should have done this first. The vacuum I just bought cost less than the motor I just replaced

Thanks to everyone for their help

Steve


Post# 411095 , Reply# 22   7/2/2019 at 10:06 by Paul (USA)        

Even though you're on your way of fixing your UC 1521's problem on your own thought I'd let you know for future reference that I just checked the store locator at aerushome.com and discovered that the store in Eugene has closed, because it lacks the "View Map" | "Driving Directions" hyperlinks. Typically, Aerus leaves closed store locations in its locator due to another store in the region taking over its phone line; although since no one answered the phone that may not be the case. So the only Aerus dealers in your region are in Portland and Tacoma.

Also, fyi the Ultralux Classic was the last version of the 1521 and was manufactured from 1992 to 1993 besides the black sales award version. It was also the last of the metal US-designed tank vacuums. The plastic tank models originated in Canada and were brought to the US market in 1985 when the US and Canadian Electrolux affiliates merged.

Thanks for your thorough posts, which will provide a good reference for anyone else who experiences similar problems. I'll be interested to know what the culprit was when you get your eBay purchase and compare its wiring with your problematic one.



Post# 411329 , Reply# 23   7/9/2019 at 15:49 by semiret (Coos Bay, OR)        
Solved

Received the Ultralux Classic I purchased over eBay yesterday & took it apart today

In comparing how the new machine was wired, it was obvious that my old machine had been wired wrong. The black & grey wires in the diagram in reply #16 were reversedI talked to my better half and she swears that the vacuum ran just find until the morning the motor burned out, when ther power nozzle started staying on even when the vacuum was turned off.

Nay3way, to make a long story short, I rewired my old vacuum to match the one I bought off eBay, and it works just fine.

I have no explanation for how the wires got switched, so I will just chalk it up to sun spots.

Now I have two Ultralux Classics. Maybe this is how vacuum cleaner collections are started :)

I have included the correct wiring diagram, just in case anyone may need it

Thanks to everyone for their help

Steve


  View Full Size
Post# 411339 , Reply# 24   7/9/2019 at 20:53 by human (Pines of Carolina)        
Glad you got it fixed...

human's profile picture
Sounds like persistence paid off. Shame you had to get a second machine to be able to figure it out but hey, you can't have too many Luxes around, can you?




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy