Thread Number: 18504
Eureka Boss 1934
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 203397   10/10/2012 at 16:47 (2,729 days old) by joejoe83 ()        

Hey guys, I recently purchased a Eureka Boss from a local thrift store for 10.00 but it only worked for a minute then shut off and never turned back on. I wanted to replace the motor, is it easy to replace? Do they still make this motor? It's a 5.0 amp. Thanks. Here is what it looks like




Post# 203408 , Reply# 1   10/10/2012 at 18:01 (2,729 days old) by vacuumfreak (Windsor, Ontario, Canada)        

vacuumfreak's profile picture
These motors are very simple to replace, but have you checked the motor carbons? If so, and all else fails, you might be able to find a good used motor, or you could buy the new 5.0 amp blender style motor thats in the newer 1934's than yours, but it will still fit into yours. If you replace it with the new motor though, you will notice that the motor is more high pitched, and doesn't sound quite like the motor that was in yours previously. I would recommend trying places like ebay etc. to try and find a new motor. They're great machines though! If you want to take the hood off, flip the machine upside down, and you will see two black screws, one on each side (left and right). Once you remove those, you can flip it back to its normal position facing up, and lift the hood off. There are 4 screws holding the motor in that you will see around it, which I believe are T25 screws. Once you have those out, the motor should just lift right out. You can simply cut, strip, and marrett the wires to the new motor, and then just screw it down, and put the hood back on and you should be good to go. I have the newer 1934A and it works great! I love how lightweight it is, although I wish it had the older motor in it, just because I like the sound of the older ones better :P

Hope this helps!
Daniel :-)


Post# 203410 , Reply# 2   10/10/2012 at 18:32 (2,729 days old) by joejoe83 ()        

Thanks man, how do I check to see if the carbons have went bad? Is thus nechanie from the 1980's?

Post# 203416 , Reply# 3   10/10/2012 at 19:44 (2,729 days old) by mieles7 (DFW, TX)        

mieles7's profile picture
This vacuum is from the 1990s, but Eureka used that same deign for most of their uprights ever since the 50's. Here's the current version of that model.

CLICK HERE TO GO TO mieles7's LINK


Post# 203417 , Reply# 4   10/10/2012 at 19:48 (2,729 days old) by vacuumfreak (Windsor, Ontario, Canada)        

vacuumfreak's profile picture
I will post a picture tomorrow of where to locate the carbon brushes. Its easier for me to explain with a picture where I can circle exactly where they are so you know where I'm getting at. I have an old Eureka upright, and the new 1934, so I will post a picture of both the new and old motor so you know which you have, and where to find the carbon brushes on them to check if they're worn out. It could also be a loose connection or short in the cord, so make sure you check all the connections when you take the hood off, or try and run the motor with a different cord if you happen to have one. Also, Im not sure on a date, but I know its an older one because of the white Dial-A-Nap dial. Mine is new, and the dial is black. I will post pictures tomorrow for further information.

Daniel :-)


Post# 203423 , Reply# 5   10/10/2012 at 20:57 (2,729 days old) by KirbyUltimateG (Troy Ohio 45373 USA)        

Hello. Your vacuum cleaner is model number 2034. The part number for the motor is 54773. I hope this helps.


CLICK HERE TO GO TO KirbyUltimateG's LINK


Post# 203428 , Reply# 6   10/10/2012 at 22:39 (2,729 days old) by HooverCelebrity ()        

Moved to contemporary forum


Post# 203474 , Reply# 7   10/11/2012 at 15:19 (2,728 days old) by vacuumfreak (Windsor, Ontario, Canada)        

vacuumfreak's profile picture
Here comes the pictures, I hope this helps! :-) The first one shows you a step I missed in taking the hood off. Using a T25 screwdriver or bit, unscrew the screw that is inside the dial. This releases the height adjustment, and it allows the hood to come off. when you put the hood back on and want to put the dial back on, lift the base up and pull down on the front wheels underneath, and then put the dial back while holding the wheels down. This will allow you to put it back in.

Daniel :-)


Post# 203475 , Reply# 8   10/11/2012 at 15:19 (2,728 days old) by vacuumfreak (Windsor, Ontario, Canada)        

vacuumfreak's profile picture
Old Motor

Post# 203476 , Reply# 9   10/11/2012 at 15:20 (2,728 days old) by vacuumfreak (Windsor, Ontario, Canada)        

vacuumfreak's profile picture
Newer Blender style motor. The old motor is called a "pancake style" motor based on its appearance.



Post# 203477 , Reply# 10   10/11/2012 at 15:22 (2,728 days old) by vacuumfreak (Windsor, Ontario, Canada)        

vacuumfreak's profile picture
Lastly, here are my two Eureka's :-) Hope this helps! Good luck! They're great machines!

Daniel :-)


Post# 203487 , Reply# 11   10/11/2012 at 17:45 (2,728 days old) by joejoe83 ()        

Thanks everyone :)

Post# 203499 , Reply# 12   10/11/2012 at 20:16 (2,728 days old) by vacuumfreak (Windsor, Ontario, Canada)        

vacuumfreak's profile picture
No problem! Let us know how you make out! :-)

Daniel :-)


Post# 203578 , Reply# 13   10/12/2012 at 16:03 (2,727 days old) by kirbykid63 (Wilmington Delaware)        
Perhaps its the switch?

I had a sanitaire that did the same thing and it turned out to be a broken switch.

Post# 203689 , Reply# 14   10/14/2012 at 09:32 (2,725 days old) by joejoe83 ()        

Maybe I should start with the switch, prior before it quit working I smelled a slight burning smell then it would not turn on again :(

Post# 203697 , Reply# 15   10/14/2012 at 11:53 (2,725 days old) by vacuumfreak (Windsor, Ontario, Canada)        

vacuumfreak's profile picture
The motor might be burnt right out. If its not the switch I would just replace the whole motor.

Just my opinion.
Keep us posted :-)

Daniel :-)


Post# 203712 , Reply# 16   10/14/2012 at 12:54 (2,725 days old) by eurekastar (Amarillo, Texas)        

eurekastar's profile picture

You can take an ohm meter (or a multi-meter) and check for continuity on the motor.  If you get a reading off the motor wires, then you know it's the switch.  If you haven't used one before, I can help you out and they're pretty cheap to buy too. 


Post# 206781 , Reply# 17   11/15/2012 at 18:27 (2,693 days old) by 052334 ()        

I just peaked in to see what this site was about. The cooperation and generosity of the contributors to this thread has to be commended.

Post# 206881 , Reply# 18   11/16/2012 at 22:20 (2,692 days old) by kirbyvacuum (Long Island New York)        
Boss1934

Hi joe i have the same vacuum with the same thing start with the switch it worked for me Doug




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy