Thread Number: 17415
kenmore heavt duty twin fan
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 187492   6/29/2012 at 01:14 (2,841 days old) by mr_mom (pittsburgh (PA))        

mr_mom's profile picture
im wondering is this is common with these models i just got this twin fan and it runs fine on both speeds and i shut it off to move my couch out and it didnt come on the headlight was on and i unpluged it and waited anhour and turned it on and samething and the next morning it came on and if i pound it on the floor three times it comes on and i would have it set on high and it would start up very slow then after that it works great if anyone know if this is common please let me know thanks




Post# 187534 , Reply# 1   6/29/2012 at 09:22 (2,841 days old) by rugsucker (Elizabethton TN)        
twin fan problem

This may need a simple repair that was more common years ago when more were in use.Step number 1-stop pounding on floor! Steps 2 and beyond-unplug,remove cover(2 or 3 screws under),remove cover above motor(1screw?),remove screw holding carbon brush,lift brush holder up carefully.The carbon brush will likely have dust & dirt built up that prevents it from sliding in sleeve.If so move brush back & forth until it moves freely,replace,repeat on other side,reassemble.Good luck(&no more pounding).

Post# 187545 , Reply# 2   6/29/2012 at 11:02 (2,841 days old) by mr_mom (pittsburgh (PA))        

mr_mom's profile picture
i dont pound it my mind was on something else when i was typeing this i should have said i tap on the hood . But i have taken it all apart and cleaned everything but im got goona give up on this. this is the only thing i can find thats close to the kenmore wide sweep but i need find a new bottom houseing the guy i got it off of had duck tape near the bag and i took it off and i found out that one of the clips that holds the bag on brok off.when i took the hood off the peice that broke off was taped under the hood with two screws and i dont know if i can super glue it back on bc its right where the bag is and i dont wannt make it worse then it is . and the bag looks like it can use a wash i might take the steam vac to it with hot water only i wanns fade the black and red




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy