Thread Number: 15687
Rainbow Question...
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 166894   1/23/2012 at 21:16 (2,998 days old) by rainbowkid107 ()        

Hi everyone. I don't know if this is just my OCD or if its something I should actually be concerned about. My Grandmum has a Rainbow e2 Platinum that she got in late July of 2009. It works fantastic and it is amazing what it picks up. My concern is the way it sounds. I added a link to a video and his Rainbow sounds different than my Grandmum's. In low speed there is the ping as it does in his video but if you listen carefully there is a deeper tone to low speed while its running. Its like the higher sound has a lower sound of the same type. I don't really know how to explain it. Then in high speed in the video it sounds like his Rainbow, but when its shut off my Grandmum's sounds NOTHING like his. I don't know if it matters or not, but I'd like to know because I have a beef with the people who sold my Grandmum her Rainbow. Wrong wands, broken dolly, dirty hepa filter, wrong attachments, wayyyy too expensive (she paid $1850.00 without power nozzle, just regular set up). We've been back there once to get the right stuff but I would like to know if they sold her a dud. Now I should also say, although I doubt that it makes a difference as it's only happened like fifteen times, is there has been water left in it. Both clean water as well a dirty. I know, its a sin to Rainbow fans. But we are very busy. Anyways, ANY reply would be very appreciated and if there is a problem you can bet your @$$ I will be on the phone with those crooks faster than you could say "DON'T DO IT!". Thanks again!
~Josh


CLICK HERE TO GO TO rainbowkid107's LINK





Post# 166974 , Reply# 1   1/24/2012 at 13:10 (2,997 days old) by massagemiracle ()        

I am trying to understand your thread, you say there is a "ping" sound in the motor? Watching your video twice I heard nothing but a normal sounding Rainbow, and I have worked on quite a few.  Has it been maintainanced? Cleaned the separator, changed the hepa filters, and yes you should never leave water in the tank after your finished with it, it will ruin the motor eventually. Water evaporates and goes up into the motor causing corroding the insides. So even if you turn it in for warrantee they won't honor it for that reason.


Post# 166983 , Reply# 2   1/24/2012 at 13:31 (2,997 days old) by rainbowkid107 ()        
The Ping...

By the ping I mean when you first push the power button there is that noise that sound like a jet. Anyways its probably just my earphones.


Post# 167038 , Reply# 3   1/24/2012 at 16:03 (2,997 days old) by djtaylor (Salt Lake City, Utah)        
Leaving the water in the tank...

djtaylor's profile picture
Another reason to empty the tank after EVERY use... bacteria grows in warm, wet places... very quickly. My mom left water in her Rainbow a couple of times and after a day or two it stunk up the house, and left the Rainbow smelly for during use for a couple of weeks. Also, the Seperator needs to be taken off and scrubbed with the tooth brush thing every time it is used to prevent dirt building up and reducing the air flow. I know that Rainbows are a bit of a pain in the arse, all the prep time and take-down time... but, they are very good vacuums. I have an old D3 that I'd hate to have to give up. It may not be a great deep cleaner, like my Kirby GSix, but I do love to use it every so often.
I suggest that you take your grandmum's Rainbow to a reputable vacuum shop and have it throughly serviced. It will make a world of difference. And you really should empty and clean it after every use, that way it lasts a very long time.
Just my two pence.
Justin


Post# 167117 , Reply# 4   1/24/2012 at 20:11 (2,997 days old) by rainbowkid107 ()        
Thank you!

Thank you so much for all of this information! So do I have to worry about the sound? I hve found a Rainbow that sounds just like my Grandmum's and if you compare the link that I'm posting now and the one in the original post you will see what I mean about the deeper tone. I will have her take it to get serviced as soon as possible.

CLICK HERE TO GO TO rainbowkid107's LINK


Post# 167118 , Reply# 5   1/24/2012 at 20:55 (2,997 days old) by mark40511 (Lexington, KY)        

mark40511's profile picture
On those two videos, it does sound a little different.....Mine sounds like the first video.....One thing I've noticed when you hear some of the 2 speed Rainbows start up on high speed on the youtube vids, sometimes it seems like the "rev up" time is a little longer than on others. In the first video when it goes to high speed, it revs up quickly (mine does too) but some other videos I've seen, when turning onto high speed, it's like a slightly slower rev up ...I wonder why? In this link below, see how much longer this Rainbow takes to REV up than the other video on high speed

CLICK HERE TO GO TO mark40511's LINK


Post# 167121 , Reply# 6   1/24/2012 at 21:31 (2,997 days old) by rainbowkid107 ()        
Okay good haha...

Okay :) I'm glad I'm not the only one that noticed this! :D So it might just be that every one of the motors is a little different. The Rainbow from the frist like I noticed was from 2009 and the second platnium in the second link was from 2008. There might've been a slight change in the motor there. I have no clue, but i will definitely make sure she doesn't leave water in her vacuum anymore. It's an old habit. She used to do that with her old D4SE. I'd find water in it constantly. :/ But I will make sure she doesn't do it anymore. I will also clean the seperator. ind you I will still give those jerks that sold it to her a piece of my mind. In the second video the guy got a fully loaded one for $1450.00 so paying $1850 for a basic setup one was crazy! I will try to make a video of her Rainbow on my phone and post it at some point.

Post# 167134 , Reply# 7   1/24/2012 at 23:36 (2,997 days old) by rainbowjoel (Dexter NM)        

Mark I wondering with dirty fans slows down. my video the link you posted wasn't cleaned yet on fans. @ Rainbowkid107 Yours is insulated compared to mine and Mark but It could be computer. they have changed the computer box design. How the fans looks like cleaned??? I think what u mean like a grin sound after turn off on high speed???

Post# 167138 , Reply# 8   1/25/2012 at 00:34 (2,997 days old) by mark40511 (Lexington, KY)        

mark40511's profile picture
Hey Joel

What's up?

When you cleaned the fans on your Rainbow does it STILL sound like that at start up or does it now sound like the first video at start up? I think you said you bought your 2 speed used, correct? So the fans did probably need cleaning. No telling how the previous user maintained it.

PS....... I found REALLY cheap Hepa Filters on Ebay for the 2 speed. I don't need a new filter for mine but I bought this for future because it was a really good price. It is aftermarket but I seriously can't tell the difference. It also fits perfectly when testing it. I put it away in case I ever need to change mine in the future


CLICK HERE TO GO TO mark40511's LINK on eBay


Post# 167143 , Reply# 9   1/25/2012 at 01:34 (2,997 days old) by rainbowjoel (Dexter NM)        

wow thats good price. I think it start up about the same. what u think on video. yeah I brought it used.

CLICK HERE TO GO TO rainbowjoel's LINK


Post# 167272 , Reply# 10   1/25/2012 at 23:54 (2,996 days old) by mark40511 (Lexington, KY)        

mark40511's profile picture
Hey Joel.

Even though you took it apart and cleaned the inside (fans & all) it still sounds slower to rev up for some reason. That is strange! I have no clue why it does that, but once it revs up, it sounds exactly like mine.


Post# 167405 , Reply# 11   1/26/2012 at 20:16 (2,995 days old) by rainbowjoel (Dexter NM)        
Mark

I guessing it's about the computer. The computer controls the motor.


Post# 167448 , Reply# 12   1/27/2012 at 07:30 (2,995 days old) by sarasvacshack ()        
I have one

that does that exact same thing. The hurricane motor sounds like a jet when it is winding up. I found it interesting that there was no electrostatic protective insulation on this model, and the wind up and wind down are much noiser than previous two speed models I have worked on. Even with clean fans. Your G'mas two speed E2 may be one of the earlier model two speeds, though I cannot imagine why they would not insulate the interior.

Post# 167730 , Reply# 13   1/30/2012 at 07:54 (2,991 days old) by thermokid (Casper, Wyoming)        
I have

two different models of the two speed Rainbows. The first one is the first two speed model Rainbow came out with. and it has that loud whining noise sounds like a jet airplane all the time that it is running.. I hate that Rainbow (I can't stand that noise) that is why it lives out in the garage in it's box never to be used again.The second Rainbow I have is the Brand new Model. It makes a little whining noise when it first turns on and gets up to speed then the sound goes away, and all you hear is the powerful air flow. I really love this rainbow......Dan

Post# 167731 , Reply# 14   1/30/2012 at 07:58 (2,991 days old) by mark40511 (Lexington, KY)        

mark40511's profile picture
I wonder how many different variations of 2 speeds there are? Mine is from mid 2006 so by the time I bought mine, the 2 speeds had been out a while. It doesn't make that whining noise at all & it starts up pretty quickly. If you look inside with the hepa taken off you can see some type of white color insulation. I've never thought it was that loud at all. To me, the PN is the loudest part of my machine.




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy