Thread Number: 8673
Electrolux Model XXX up and running finally.
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 96333   4/18/2010 at 02:02 (3,467 days old) by electroluxkirby ()        

I finally got a new hose and a cord for my XXX. She runs pretty good for her age, the suction seems a little weak compared to the AE, and Olympia One. I think it might have something to do with the cloth bag, so I bought a new off of eBay yesterday morning. The hose was made from the ends off of the original hose. The is is not that tan or grey plastic stuff, it's a black white or black and silver checkerboard design, the guy that made the hose said that the hose is crush proof. I think it has a little vintage look to it. Here's a close up picture of it.






Post# 96342 , Reply# 1   4/18/2010 at 07:17 (3,467 days old) by arh1953 ( River Park, in Port St. Lucie, Florida)        

arh1953's profile picture
I think that'll set off your XXX really well. Mine has a pale green woven hose that looks pretty spiffy on it.

Post# 96353 , Reply# 2   4/18/2010 at 08:57 (3,467 days old) by luxg ()        

That looks like genuine Lux hose!! You will have to take a picture of it on the machine!!

Post# 96358 , Reply# 3   4/18/2010 at 09:10 (3,467 days old) by suckolux (Yuba City, CA)        

suckolux's profile picture
the suction on mine is noticeably less than my Silverado, guessing smaller motor or different fan set up? Dave, what's the right answer?

Post# 96363 , Reply# 4   4/18/2010 at 10:14 (3,467 days old) by electroluxkirby ()        

Here it is connected to the new hose. I'm thinking about have a new hose made for the Olympia One and AE. The hose only cost $17 and some odd cents he used the ends from the original hose that had cracked and split open in several places.

Post# 96370 , Reply# 5   4/18/2010 at 12:08 (3,467 days old) by electrolux~137 ()        

That hose does look really nice with your XXX. That in mind, the XXX is -not- as powerful as a Silverado! However, the later XXX had the same motor [and fan configuration] that was used up until the late version of the AE; it should have more than sufficient power for straight-suction cleaning. (Remember what Stan Kann said!)

Getting a new bag probably won't make a lot of difference; you could have vacuumed the bag with another vacuum and gotten it clean. You might want to check the rear filter -- if it is all clogged with black powder (from the carbon brushes), it should be cleaned as thoroughly as possible, or else replaced. That might make a significant difference.



Post# 96372 , Reply# 6   4/18/2010 at 12:12 (3,467 days old) by suckolux (Yuba City, CA)        

suckolux's profile picture
and how much later would have the larger motor?

Post# 96378 , Reply# 7   4/18/2010 at 12:26 (3,467 days old) by suckolux (Yuba City, CA)        

suckolux's profile picture
Should have said 535 watts here

Post# 96384 , Reply# 8   4/18/2010 at 12:57 (3,467 days old) by luxg ()        

Wow Jim, that hose looks great on the XXX!!

Post# 96391 , Reply# 9   4/18/2010 at 14:10 (3,466 days old) by suckolux (Yuba City, CA)        

suckolux's profile picture
would love to have a newer hose that pretty, mine is beige plastic from 25 years ago, I think grocery store I found it. Same on the Compact, so probably. If only the Compact sounded as sweet.

Post# 96392 , Reply# 10   4/18/2010 at 14:13 (3,466 days old) by a007kirbyman (--->> Originally My Mom <<--- (now Wisconsin))        
Jim & the 'new' Lux hose...

a007kirbyman's profile picture
Hello Jim.

That L@@Ks a lot like the hoses that were used on the Heritage & Legend models of Kirbys, H II & H II L color in particular.

Later I saw the material used on several cleaners. (I don't know "who" actually invented it. Hopefully, Kirby did. ~~LOL)

Cheers & hagd all.

Bill

FYI, Ps: That hose material is NOT 'crush-proof' as the guy stated to you. I have seen them 'crushed' on different brands over the years. It is 'crush-resistant' in that it will USUALLY tend to 'fold over'.


Post# 96400 , Reply# 11   4/18/2010 at 14:53 (3,466 days old) by suckolux (Yuba City, CA)        

suckolux's profile picture
Yes! It does look like my old Legend hose, early paper bag inside I think, had rotation light on beater head, wish I still had that, paid $15 at yard sale with 2 boxes of attachments, still have some of them. Really nice machine, smaller head to move around, liked the bag inside the bag, good capacity!

Post# 96412 , Reply# 12   4/18/2010 at 16:53 (3,466 days old) by electroluxkirby ()        

I meant crush resistant, not crush proof. A guy on the bus said it looks like have a Kirby hose there. I said that it was an Electrolux hose, he replied that's even better, you can't beat an old Electrolux. So we talked vacuums until I got to my stop. My hose for the Olympia One is that same material as this hose but it is a light tan color. I would like to have all my hoses match the new one.

Post# 96415 , Reply# 13   4/18/2010 at 17:43 (3,466 days old) by electroluxkirby ()        
You might want to check the rear filter.

It's pretty dirty, how can it be cleaned. I also washed the cloth bag in warm water with some Dawn dish washing soap, and let it air dry for a couple weeks.

Post# 96420 , Reply# 14   4/18/2010 at 19:43 (3,466 days old) by electrolux~137 ()        

You can wash the filter in warm soapy water.

Treat it gently -- don't scrub it, just let it soak in a basin-full of water, then swish it around in the water for a minute or so.

Rinse well under running clear water, then dry on a clothesline (or otherwise outside) -- do not machine dry or it will shrink.



Post# 96423 , Reply# 15   4/18/2010 at 20:09 (3,466 days old) by gsohoover (Greensboro, NC)        

Very Nice. How is that cord coming out?

Post# 96427 , Reply# 16   4/18/2010 at 20:45 (3,466 days old) by electroluxkirby ()        

The cord is working perfectly! Thank you again for the cord. I have a new cloth coming hopefully this week.

Post# 96429 , Reply# 17   4/18/2010 at 21:08 (3,466 days old) by gsohoover (Greensboro, NC)        

Great! Glad to hear it is working out.

Post# 96815 , Reply# 18   4/22/2010 at 12:39 (3,463 days old) by electroluxkirby ()        

I washed the filter today, and it disintegrated on me. I called the guy that made me the hose and he said to bring the metal ring in and he will make me filter for it.




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy