Thread Number: 41727  /  Tag: Brand New Vacuum Cleaners
Weird thing happened with my vacuum today
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 441319   4/30/2021 at 23:44 by mark40511 (Lexington, KY)        

mark40511's profile picture
My daily driver (Cirrus CR79) which I really like BTW - I went to use it today as I do most every other day and as I turned it on I noticed a strange sound and I smelled what I can only describe as hot metal or possibly rubber, almost like something was to the point of burning but I saw no smoke. I couldn't tell. The sound wasn't horrible but I heard something that just didn't sound right... so I shut the machine off..I turned it over, took the bottom plate off, checked the belt & brush roll and everything looked perfectly fine. I turned it back on once more and pulled the wand out and felt low suction and quickly turned off again.

Not long ago I had changed the belt. The bag was pretty full but not packed... If my calculations are correct, this machine is about 2 and a half years old. I recently bought a new HEPA but I've been putting off changing it because I was still feeling decent airflow through the filter, even though it looked loaded with carbon dust. I guess I just thought I could get a bit more life out of it since the HEPA bags do such a good job.

So, I put a new HEPA bag in (the bag chamber was spotless BTW) and I went ahead and put the NEW HEPA filter on and everything was perfectly fine from then on. I'm really not sure WTH happened. A couple of days ago the suction was perfectly fine..(Not the suction of a brand new bag but maybe a 10% loss.. Nothing was overly plugged up and there were no strings or anything in the brush roll. I keep everything spic and span with my vacuum...

One last thing......Somehow the suction relief on the hose that goes into the very back of the vacuum was fully opened. I never open that so not sure how that happened.

Does anyone have any clue what could have happened. Was the HEPA filter plugged enough for this to happen even though air was coming out of it? Would the bag have been totally plugged up even though the BAG change indicator was not on? I used it for about an hour and a half and everything seemed normal from that point on.. I hope my vacuum isn't dying.. If something does happen, are these repairable? They certainly aren't TOL vacuums but at the same time they are not cheap plastic vacuums either.

thanks


  View Full Size



Post# 441344 , Reply# 1   5/1/2021 at 21:48 by Lesinutah (Utah)        
Im

lesinutah's profile picture
If it was likely anything it would be the bag. It just sounds like a clog in the hose and maybe newer bag and filter unclogged the clog. It's only a guess but odd things happen.
I have researched the cirrus vacuums and there rated high and perform well. I'm not sure there built to last 30 plus years. I do know there not a plasticvac crap. There solid quality and performance without spending half your yearly salary.


Post# 441347 , Reply# 2   5/1/2021 at 22:33 by mark40511 (Lexington, KY)        

mark40511's profile picture
Ya. I've never experienced a clog in a vacuum before. I guess it was possible. The bag full indicator works but it wasn't lit up when this happened.. I will say this: Used again today - fresh bag, fresh filter. The thing I notice...I also remember this same thing happening with my Shark vacuum that I had for about 4 and a half years. At first turn on - for like the first 2 or 3 minutes of using the vacuum, it's like a hot motor smell. Continuing using the vacuum and it fades...Yea, this vacuum is like $450 retail so it's definitely not a big box vacuum




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy