Thread Number: 39199  /  Tag: Recent Vacuum Cleaners from past 20 years
Kirby G4 Noise
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 415913   11/14/2019 at 16:15 (262 days old) by Kirbytex85 (Houston, TX)        

kirbytex85's profile picture
Just got a G4 and G6 and both are making an odd noise once the motor is shut off. Itís coming from the transmission area and is not the clicking sound. Luckily neither make that. Canít tell if it bearing or not. Has anything else had any odd sounds? Almost sounds like bearings but is back by trans area.




Post# 415915 , Reply# 1   11/14/2019 at 18:55 (262 days old) by Lesinutah (Utah)        
Guess

lesinutah's profile picture
I'm guessing carbon brushes are going bad. My old g4 had a weird noise and it was the carbon brushes.
Les


Post# 415921 , Reply# 2   11/14/2019 at 22:14 (262 days old) by Kirbytex85 (Houston, TX)        

kirbytex85's profile picture
Thanks Les. With I could post the sound on a video here.

Post# 415923 , Reply# 3   11/14/2019 at 22:44 (262 days old) by KirbyClassicIII (Milwaukie, Oregon)        
Kirbytex85

kirbyclassiciii's profile picture
Dustin,

Are you sure the problem you're facing isn't coming from the Tech Drive when it's engaged? Is that the strange sound you're talking about?

~Ben


Post# 415929 , Reply# 4   11/15/2019 at 10:01 (261 days old) by Kirbytex85 (Houston, TX)        

kirbytex85's profile picture
No itís when you turn off the machine and motor has almost stopped turning.

Post# 415935 , Reply# 5   11/15/2019 at 13:30 (261 days old) by Kirbytex85 (Houston, TX)        

kirbytex85's profile picture
I took the trans out, cleaned it, put a dab of oil on the axle and it it so much better now.

Post# 416024 , Reply# 6   11/16/2019 at 23:23 (260 days old) by Lesinutah (Utah)        
Nice

lesinutah's profile picture
Glad you got it fixed. I was green and took mine down to transmission but seen Sparks. I took it and got it serviced and it was carbon brushes. If I knew now what I knew then I could have easily fixed it.
It sounds like you are pretty handy taking out transmission. I think your g4 is in good hands.
Les


Post# 416098 , Reply# 7   11/17/2019 at 19:52 (259 days old) by Kirbytex85 (Houston, TX)        

kirbytex85's profile picture
Les,

Thanks! Yes Iíve worked on a few. When I have time Iíve got the G4, G6, and another Ultimate G to work on. Iíve been busy instead restoring a Heritage.

These Kirbyís are pretty easy to work on and it surprises me how many people think they are broke and toss them.





Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy