Thread Number: 38609  /  Tag: Recent Vacuum Cleaners from past 20 years
Royal Power Tank Motor Sparking—Is this normal?
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 410446   6/14/2019 at 01:01 (180 days old) by vacuumman (California)        

I noticed some sparking coming from the carbon brushes on my Royal Power Tank. The video I attached shows the sparking that appears when the vacuum is turned on. The brushes still appear to be long and have not majorly worn away. Is this behavior normal? If not, how can I fix this machine?
Thanks.


CLICK HERE TO GO TO vacuumman's LINK





Post# 410447 , Reply# 1   6/14/2019 at 02:08 (180 days old) by panasonicvac (Northern Utah)        
It's normal

panasonicvac's profile picture
I use a commutator cleaning stone to polish the armature while running, works everytime.

Post# 410449 , Reply# 2   6/14/2019 at 04:31 (180 days old) by huskyvacs (Northern Indiana)        

huskyvacs's profile picture
If someone just recently replaced the brushes, this can happen until they grind down their contour to the unique shape of the armature. But that commutator does look a bit filthy, a little polishing couldn't hurt.

Post# 410453 , Reply# 3   6/14/2019 at 09:09 (180 days old) by Electroluxxxx (Syracuse, NY )        

electroluxxxx's profile picture
Looks to be running normal.

Post# 410491 , Reply# 4   6/15/2019 at 01:07 by broomvac (N/A)        

broomvac's profile picture
That looks very healthy, actually.

I always recommend against sanding/polishing/refinishing commutators. For one, there’s no reason to do so. If the motor is running fine, that means that there isn’t a highly resistive layer between the commutator and the brushes, so cleaning the commutator wouldn’t accomplish anything. If the motor is not running well, then cleaning the commutator only treats the symptoms, not the root cause of your motor’s problems.

The other reason to not do it is that it does remove commutator copper which you will never get back. It’s kind of like doing a burnout in your car; you’re intentionally abrading away your tires. Not only that, but if you polish by hand, there is the potential to remove this material nonuniformly, leaving your commutator surface uneven. 👎

If I were you, I’d leave your Royal be. By the way, it looks to be a quality motor. I believe that is a Lamb/Ametek unit.





Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy