Thread Number: 36328  /  Tag: 50s/60s/70s Vacuum Cleaners
Electrolux AP 280 power head won't run
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 389533   3/31/2018 at 14:25 (258 days old) by Hublocker (Victouver)        

Thank you to everyone who helped me figure out how to take the cover off my Electrolux AP 280 power head.

The brush was worn out on the one head i had but i had a curbside found one with a much better brush and overall newer less-used one so i thought at least I could get the brush out of it. For some reason a previous owner had cut the pig tail right off.

then I had the bright idea to take the pig tail from my worn head, install it in the newer looking one and tried that, but the motor doesn;t work now. Tried my old head and now that motor won't turn either.

My wife reminded me that she quit using the power head a few years ago because the re-set fuse kept blowing completely and it cost a fortune to replace it.

Oddly enough it worked for me last week but with the worn brush it was ineffective on the carpet. That's why I thought I would cannibalize the one with the cut-off pig tail for the brush or just use it as is with my old pig tail.

Now neither one works.

Any ideas? Is there a way to bypass that over sensitive re-set switch or a cheap way to repair it myself?

Thank you.






Post# 389540 , Reply# 1   3/31/2018 at 18:30 (258 days old) by MadMan (Chicago, IL, USA)        

madman's profile picture
If the reset thingy is a fuse - it's best not to bypass it. It's popping for a reason, best to find the problem and fix it. If it's a breaker, breakers do go bad sometimes, maybe it just needs to be replaced? I'm not entirely clear on that part.

The pigtail wire may have an internal breakage. Ohm each wire from end to end with a multimeter, each should be 0-2 ohms. If it reads more or doesn't register on the meter at all, it's open.

Or, perhaps that fuse thingy is to blame. Run the vac and put a test the voltage across the powerhead plug at the machine side, should have voltage, probably ~120vac.

Time to do some diagnosis.


Post# 389583 , Reply# 2   4/1/2018 at 15:17 (257 days old) by Hublocker (Victouver)        
Fixed it

Figured it out.

Greenhorn problem.

I was not connecting the electrical fitting between upper and lower tube correctly.

Cleans like a hot damn now.





Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy