Thread Number: 35839  /  Tag: 50s/60s/70s Vacuum Cleaners
Royal 801
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 384605   1/21/2018 at 14:51 (271 days old) by Kirbyvertibles (Independence, KS)        

kirbyvertibles's profile picture
Hello all,
During my last trip to St. Louis last year I bought a red Royal 801.
I am looking for the correct era motor for it as this thing is as loud as an 80s/90s model. I don't know much about them but I'm pretty sure this one shouldn't be this loud. How would I tell if it had a motor replacement? If I can get a quieter motor ill add to collection, if not I intend to sell it.





Post# 384608 , Reply# 1   1/21/2018 at 16:36 (271 days old) by KirbyClassicIII (Milwaukie, Oregon)        
kirbyvertibles

kirbyclassiciii's profile picture
Phillip,

It's likely the armature and field in it is for 5.4 amp machines.

The latest armature and field fitted in the 801 was for 4.5 amp motors, and that was in the 1985-87 period. The armature was 1-880001-000 and the field 1-880002-000.

The correct armature and field you're likely looking for are part numbers 1-801001-000 and 1-801002-000 respectively, but if you wish to use the nine-blade replacement fan (screw on type), here's the 1-608001-000 armature used on 3 amp machines made from 1976-85.

~Ben


CLICK HERE TO GO TO KirbyClassicIII's LINK on eBay


Post# 384623 , Reply# 2   1/21/2018 at 19:25 (270 days old) by kenkart (Mocksville, NC)        
I have a 58 model

801 and its as quiet as a mouse,one of my favorite vacs.

Post# 384730 , Reply# 3   1/24/2018 at 01:24 (268 days old) by hygiene903 (Galion, OH)        

hygiene903's profile picture
I have 3 801's and they're all quiet! Don't know why yours would be so loud, unless someone put a newer, higher amp motor in it, or perhaps the bearings are going bad.
Jeff


Post# 384739 , Reply# 4   1/24/2018 at 08:35 (268 days old) by kirbyvertibles (Independence, KS)        

kirbyvertibles's profile picture
Hi Jeff, I think someone has put in a newer motor. I mean it sounds fine like the motor is running properly, just way to loud for this machine.




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy