Thread Number: 35228  /  Tag: Recent Vacuum Cleaners from past 20 years
Older Henry - what bag connector?
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 379261   10/5/2017 at 01:38 (354 days old) by seanc (Cambridge, United Kingdom)        

Hi all,

I have a Henry (from the 90's I think) - 900w motor, black wheels with no covers, single rocker switch and power outlet.
It doesn't have a bag connector in the tub. I bought one, but it seems to be a newer version as it's too wide to slot into the opening.

Does anyone know what the correct part is, or what it should look like?

I also took a look at the motor. The armature is a silvery colour where the carbon brushes meet, no hints of copper. Not sure if this is just the carbon on the commutator or whether it's really worn. Seems to run fine though.

Thanks,

Sean.





Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy