Thread Number: 26026
Electrolux 2100 Problem (help needed!)
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 291786   8/3/2014 at 16:54 (3,404 days old) by eurekastar (Amarillo, Texas)        

eurekastar's profile picture
I have an Electrolux 2100 that turns on but immediately turns off when the hose is attached. The bag change light also comes on. With the hose off, it runs fine until I place my hand up against the intake. It then immediately shuts down, with the bag change light also coming on. I don't think the bag is the problem because it is brand new.

I don't know anything about these newer models. I've only serviced older models. But I'm guessing there is a problem with the airflow sensor.

I bought it from a lady a few years ago who rarely ever used it, because her housekeeper usually brought her own vacuum. It still looks almost brand new. I use it from time to time and have never had a problem until now.

Any thoughts would be appreciated!

  View Full Size
Post# 291791 , Reply# 1   8/3/2014 at 17:14 (3,404 days old) by marks_here (_._)        

marks_here's profile picture
Turn the dial one way or another & keep testing it until it stops popping open

Post# 291792 , Reply# 2   8/3/2014 at 17:22 (3,404 days old) by eurekastar (Amarillo, Texas)        

eurekastar's profile picture
Changing the dial doesn't seem to resolve the problem. I suspect this part is the guilty culprit.


Post# 291793 , Reply# 3   8/3/2014 at 17:28 (3,404 days old) by tig21er (Indiana)        

like a bad auto control valve. That could be a bad o-ring that is in it.

Post# 291797 , Reply# 4   8/3/2014 at 18:03 (3,404 days old) by marks_here (_._)        

marks_here's profile picture
Correct. That's it ... Was going to tell you that if the dial didn't work

Post# 291829 , Reply# 5   8/3/2014 at 22:08 (3,403 days old) by eurekastar (Amarillo, Texas)        

eurekastar's profile picture
Well, this should be fun! I've never torn into one these plastic body models. A new adventure!

Post# 291833 , Reply# 6   8/3/2014 at 22:30 (3,403 days old) by marks_here (_._)        

marks_here's profile picture
Open the front & the sides slide off, the the back cover is held by 4 pins, you'll see them once it's open

Post# 291834 , Reply# 7   8/3/2014 at 22:32 (3,403 days old) by marks_here (_._)        

marks_here's profile picture
Ohh watch the wiring..once it's open you might want to write down what wires go where or take a pic of it

Post# 291838 , Reply# 8   8/3/2014 at 22:36 (3,403 days old) by tig21er (Indiana)        

don't have to take it all apart to check. The dial will come off from the top and expose the auto valve. When you unscrew the dial from the assembly you will find one of the two O-rings holder is broken. Buy a new valve and just put the dial back on the assembly . Let me know if that is your problem and I will make sure you can get it back together.

Post# 291844 , Reply# 9   8/3/2014 at 22:44 (3,403 days old) by marks_here (_._)        

marks_here's profile picture
Oh sorry, I gave out wrong info

Post# 291845 , Reply# 10   8/3/2014 at 22:48 (3,403 days old) by tig21er (Indiana)        

glad to see you caught the mistake early.

Post# 291848 , Reply# 11   8/3/2014 at 22:51 (3,403 days old) by tig21er (Indiana)        

valve problem is something that I came across just in the last two years. Taught how to fix by Franchise Owner that was a Service Manager first.

Post# 291850 , Reply# 12   8/3/2014 at 22:55 (3,403 days old) by marks_here (_._)        

marks_here's profile picture
Is it the other ones without the dial you slide apart?

Post# 291879 , Reply# 13   8/4/2014 at 05:55 (3,403 days old) by thermokid (Casper, Wyoming)        
Electrolux 2100

I have that same vacuum and the same problem. I suspected that dial had something to do with the problem. My 2100 will run for awhile if you lay it on its side...I gave up trying to take it apart though.. I will have to try taking the top off again.. Dan

Post# 291898 , Reply# 14   8/4/2014 at 10:20 (3,403 days old) by kloveland (Tulsa)        

kloveland's profile picture
Jimmy told me on a previous thread that it is best to take these apart face down. Then you won't have to disconnect the wires on the top. I found out the hard way when I first took one apart with the control panel on top. After the tank is disassembled, check to see if all the hoses are connected and clear. Those later Elux plastic tanks seem to have a lot of power.

Post# 291903 , Reply# 15   8/4/2014 at 11:14 (3,403 days old) by tig21er (Indiana)        

at the dial on top. Pull it up then you will see the control underneath. No need to take the body apart to check the problem. I will try and locate a diagram to take body apart. If you take the body apart a don't know what you are doing you could be in big trouble.

Post# 291905 , Reply# 16   8/4/2014 at 11:32 (3,403 days old) by tig21er (Indiana)        

you do take it apart dodo wiring diagrams or you will have problems.

Post# 291915 , Reply# 17   8/4/2014 at 14:57 (3,403 days old) by eurekastar (Amarillo, Texas)        

eurekastar's profile picture
That's for all the information! This all will help a lot if I need to take it apart!

Post# 291923 , Reply# 18   8/4/2014 at 16:01 (3,403 days old) by DesertTortoise ()        

And here I was thinking it was a blocked hose. Lots to learn here.

Post# 291969 , Reply# 19   8/4/2014 at 22:10 (3,402 days old) by sbakerde (Millsboro, DE )        
Those valves always go bad.

Great vacuum but the whole control valve set up in there is useless. Worked great in the metal tanks. Rather than replace it or I try to repair it I just remove the tube going from the control valve to the switch block. Then it can't shut off. The motor has a thermal switch so it's not needed to protect the motor in the event of a clog. And we are all smart enough to know when the bag needs changing.

It is best to remove the bottom from the rest of the vacuum and not the top cover. Once the bottom is off just move the bag chamber out and the valve switch and all the little tubes are right there.

Post# 292009 , Reply# 20   8/5/2014 at 10:15 (3,402 days old) by tig21er (Indiana)        

valves do not always go bad. As a youngster I can understand what you think. I have been in the business 58 years and never say always. Some do go bad but not that many. As a man in the business you are just beginning . Over the years you will find new stuff to say needs changing but the manufacturer will be the determining factor as well as the customer. If I had a problem on my automatic I would want it fixed. If you don't want to fix yours fine.

Post# 292014 , Reply# 21   8/5/2014 at 10:56 (3,402 days old) by dysonman1 (the county)        

dysonman1's profile picture
I'm surprised no one has suggested the obvious first remedy. The clear air tube that goes from the automatic control dial to the intake tube in the front cover, should be removed and a thin wire (like a bread twisty tie with the plastic covering removed) should be inserted to clean out the very tiny hole. It always clogs, and the machine shuts off as soon as any kind of restriction is placed over the front intake opening.

Post# 292015 , Reply# 22   8/5/2014 at 11:06 (3,402 days old) by tig21er (Indiana)        

Tom, that's usually what I go for.

Post# 292024 , Reply# 23   8/5/2014 at 13:50 (3,402 days old) by DesertTortoise ()        

How much do these vacuums cost and they have these kinds of problems? Just asking .................

Post# 292901 , Reply# 24   8/11/2014 at 11:11 (3,396 days old) by DJub85 (Virginia)        

How much do they cost? Depending on your Aerus dealer, $800+ for a brand new 2014. But the base model, the Lux Classic, does not have an adjustable control valve and probably doesn't suffer from this problem.


Furthermore, I've not come across very many of these threads mentioning control valve problems. In my personal collection are 8 models dating from 1968 to 2014. All of them have the control valve, and none of them have had any problems. Electrolux has been using control valves that are essentially the same since the beginning of time. They grew their reputation on the innovation and reliability of their products. If the original control valve design was flawed or unreliable, there would be no Aerus today, period. I wouldn't be afraid of them because of the valve.

Post# 292929 , Reply# 25   8/11/2014 at 12:49 (3,396 days old) by DesertTortoise ()        

Hmmm, my Epic 8000 apparently doesn't have this feature. There are three motor speeds selected electronically by a switch on the handle. That is it for suction control. It's plenty.

Post# 386962 , Reply# 26   3/1/2018 at 12:17 (2,098 days old) by luxkid1980 (Richmond, Virginia)        

I know this is an old post, but I am having this issue with my Epic 6500. I recently purchased a new control valve online, but the vacuum would cut off as soon as the hose was connected. The original valve malfunctioned at some point and I just disconnected the bag full indicator and this fixed the problem. The new valve did not correct the issue when it was installed. I was thinking that as dysonman mentioned above that a thin wire should be used to clear out a small hole. Where is this located? Can anyone provide a picture so I know what I am looking for?

Post# 386969 , Reply# 27   3/1/2018 at 15:46 (2,098 days old) by lux14 (Leawood Kansas)        

I think what is meant is to take a pipe cleaner or twisty and make sure there is no obstuction in any of the tubes. I have this problem with mine and was able to fix it. Let me know if you need anything else. Also, basic question. When you put the new dial in, you made sure the dail was turned on to the middle of the dail correct? If you have the dail set on the lowest setting it would most likely cause the same problem. Hope that makes sense.

Post# 386989 , Reply# 28   3/2/2018 at 07:14 (2,097 days old) by luxkid1980 (Richmond, Virginia)        

Thanks Lux14. Yes, I tried all settings on the dial, but I will take it apart and try it again and make sure the clear vacuum tunes going to the control valve are cleaned out.

Post# 387668 , Reply# 29   3/10/2018 at 06:52 (2,089 days old) by vacuumguy91 (Hoover Central)        

vacuumguy91's profile picture
I recently had the same issue with my Epic 6000 SR Canister...I just disconnected the tubing to the valve and it works fine now...I took the canister apart face down, was able to disconnect the tube quite easily and put the canister back together...took maybe 10 minutes. Good Luck

Post# 389471 , Reply# 30   3/30/2018 at 16:27 (2,069 days old) by DJub85 (Virginia)        

You mentioned only working on the older metal canisters... the control valve and how it works is still the same. It's just located in the canister body instead of in the bag door. Knock on wood I've never had a control valve problem.

Post# 467438 , Reply# 31   11/10/2023 at 15:42 by RichardR (North Carolina)        

I can see this thread started more than 9 years ago but it helped me get my 2100 going again when it started shutting off when attempting to attach the hose.
(ie, ran fine with hose off)
I just disconnected that one vacume hose to the switch as you suggested and wala!
Question for you:
1) Will the vacume bag full light still come on when it senses the bag needs to be replaced?
2) Will the vacume still shut off when the bag is full?
Thanks again for all your help
PS: The tube leading to the switch was completely clear
I did not check the other tubes

Post# 467439 , Reply# 32   11/10/2023 at 17:21 by vacuumman (California)        

Disconnecting the hose bypass the automatic shut-off mechanism, meaning that the vacuum is no longer able to determine when the bag is full. Therefore, it will not activate the red light or shut down when the bag is full. I believe you may have to check to see if there are any blockages in the clear hoses (or potentiallly replace the clear dial mechanism) if you want to restore the original functionality.

Post# 467442 , Reply# 33   11/10/2023 at 19:45 by Kloveland (Tulsa)        

kloveland's profile picture
I would rather replace the bag valve than disabling it. I canít stand it when people Jury rig stuff to make it work. Just my personal preference.

Post# 467444 , Reply# 34   11/10/2023 at 19:49 by Kloveland (Tulsa)        

kloveland's profile picture
If the hoses are clear open up the bag valve. The stem screws out. I guarantee the bottom seal is off and you can probably see little bits of plastic where it is broken. This seems to happen more often on the plastic models. Then to 1205 metal style canisters.

The valve will have to be replaced. They are about $38 on eBay.

Post# 467469 , Reply# 35   11/12/2023 at 15:11 by Human (Pines of Carolina)        

human's profile picture
I have a Diplomat LX, which is essentially the same machine, that I rescued from beside a dumpster in the spring of 2020. It had this same problem and I just disconnected one of the clear vacuum lines to get it running. I keep saying I'll get another valve for it, but I've had the thing for about three years, use it semi-regularly, and really haven't missed it.

Forum Index:       Other Forums:                      

Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In

New Members
Click Here To Sign Up.

Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy