Thread Number: 15661
older hoover windtunnel with no suctoin :(
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 166614   1/21/2012 at 18:34 (2,992 days old) by super-sweeper (KSSRC Refurbishment Center)        

super-sweeper's profile picture
hello again all,
i've had a hoover windtunnel (early 1990's one) for a while now,and it's never had barely any suctoin,especialy at the hose end.
i've even repalced the tank filter.
any help is greatly appreciated.
thank you again.

-Alex.





Post# 166619 , Reply# 1   1/21/2012 at 19:01 (2,992 days old) by jmurray01 (Scotland)        

jmurray01's profile picture
If the filters are clean, the bag isn't too full and there are no blockages, it sounds like the motor either isn't spinning at the correct RPMs or the fan has been worn out by dirt getting through the Pre-Motor filter.

Post# 166622 , Reply# 2   1/21/2012 at 19:16 (2,992 days old) by super-sweeper (KSSRC Refurbishment Center)        
jmaurry,

super-sweeper's profile picture
it's bagless by the way :D.
and i'm wahing the filters right now,an if that doesn't work tah i'll take it apart.


Post# 166625 , Reply# 3   1/21/2012 at 19:37 (2,992 days old) by broomvac (N/A)        

broomvac's profile picture
Much more likely than fan erosion or CERTAINLY RPM reduction (which he would definitely notice) is that there is a clog or a bad seal somewhere.

Post# 166630 , Reply# 4   1/21/2012 at 19:56 (2,992 days old) by super-sweeper (KSSRC Refurbishment Center)        
broomvac-

super-sweeper's profile picture
it's missing the bagless chamber's cover,i have a cardboard thingy over it though.
still,it's never had good suctoin :(.


Post# 166633 , Reply# 5   1/21/2012 at 20:46 (2,992 days old) by broomvac (N/A)        

broomvac's profile picture
Well, that makeshift cover is probably a huge part of the problem! That seal is crucial in these vacuums!

Post# 166657 , Reply# 6   1/22/2012 at 04:05 (2,992 days old) by jmurray01 (Scotland)        

jmurray01's profile picture
Using cardboard as a cover certainly isn't helping.

Get a proper cover and try it then.


Post# 166662 , Reply# 7   1/22/2012 at 07:51 (2,992 days old) by thermokid (Casper, Wyoming)        
Hoover Windtunnel Bagless

It also might be the gate that turns the suction from the carpet part up to the hose when you put the handle in the upright position. When I worked at Hoover, we always had Bagless windtunnels come in with that problem. There is a little suction gate that isn't closing all the waY because it gets dirt and stuff stuck in it so it isn't letting the gate shut all the way switching the suction to the hose. Dan

Post# 166666 , Reply# 8   1/22/2012 at 09:22 (2,992 days old) by jmurray01 (Scotland)        

jmurray01's profile picture
Good idea Dan!

Post# 166676 , Reply# 9   1/22/2012 at 12:05 (2,992 days old) by super-sweeper (KSSRC Refurbishment Center)        
idk about a gate,

super-sweeper's profile picture
it just doesn't have barely to none hose suctoin.

Post# 166679 , Reply# 10   1/22/2012 at 12:21 (2,992 days old) by sanitairered (Michigan)        

sanitairered's profile picture
If you want to restore *suction*, buy a new plastic top instead of using a makeshift cardboard one. That is without a doubt your problem.

Post# 166709 , Reply# 11   1/22/2012 at 15:55 (2,991 days old) by jmurray01 (Scotland)        

jmurray01's profile picture
That was my view Floyd.

If the suction is still poor after replacing the cover, you have another problem, but at least try getting a new cover first.


Post# 166778 , Reply# 12   1/23/2012 at 08:39 (2,991 days old) by fan-of-fans (USA)        

fan-of-fans's profile picture
Yeah, the bagless part has to be sealed or it won't work. Also I think that machine would be after 2000 at least. The bagged Windtunnel came out about 1997 or so and I think the bagless followed after a few years.

Post# 167140 , Reply# 13   1/25/2012 at 00:43 (2,989 days old) by jmurray01 (Scotland)        

jmurray01's profile picture
I'm sure I saw an advert from 1994 which featured a Bagged HOOVER Windtunnel...

Perhaps I am mistaken.

I do doubt that it was from the early 1990's though if it is Bagless, as over here in the UK, the first HOOVER upright Bagless cleaner was in the early 2000's.





Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy