Thread Number: 15632
need help defeating a safety mechanism
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 166228   1/18/2012 at 03:31 (3,004 days old) by Vacuumfreeeke ()        

My Haan steamer was working perfectly, then all of a sudden, the water empty red light came on and and the heating element won't come on when that light is on. The thing is full of water and there is no reason for the light to be on. I opened it up, but it looks pretty complicated and I'm not sure what to disconnect to defeat the safety mechanism. I just ordered pads on amazon and now the silly thing doesn't work! If anyone can help, I'd really appreciate it!

Here's a picture of the inside






Post# 166236 , Reply# 1   1/18/2012 at 06:29 (3,004 days old) by tolivac (Greenville,NC)        

Is the Haan floor steamer still under warranty?I would not recommend defeating ANY safety devices in a heating-steam type machine.Take the machine to the Haan dealer where you bought it.the dealer should be able to fix the machine.Maybe there is a clog of some kind in the unit preventing it from working-in that case the safety device is doing its job-preventing damage.

Post# 166250 , Reply# 2   1/18/2012 at 10:12 (3,004 days old) by Vacuumfreeeke ()        

I bought it at the good will. It worked fine when I bought it and all of a sudden its not working. The safety device is there to turn off the heater when it runs out of water.... it is full of water and the thing is still activating. It isn't doing its job, it is malfunctioning.

I have a plan though. :o)


Post# 166253 , Reply# 3   1/18/2012 at 10:43 (3,004 days old) by swiveltop (Galveston, TX)        

Hi, The switch on the left is probably the safety switch for low water and the white wire looks like it is not connected, If thats not it and you have an ohm meter I can tell you what else you can troubleshoot, I wouldn't defeat any safety device as it may make it a fire hazard.

Post# 166383 , Reply# 4   1/19/2012 at 12:22 (3,002 days old) by kenmore81 (Warwick, RI)        

kenmore81's profile picture

The one to the left is the on/off button, the thermal protection is im thinking is at the end of the black wire, first try cleaning it with half boiling water/half vinnegar from a pot directly into the steamer, let it sit for a while. Its probably limescale and or calcium thats built up in the chamber making the thermal protection think its to hot.

Let us know how you make out Bobby.

P.S. I wouldnt disable it either and im a dare devil, I remove those labels on the mattresses and pillows lol ;)


Post# 166402 , Reply# 5   1/19/2012 at 16:36 (3,002 days old) by twocvbloke ()        

Just remember, if you disable things designed to protect you, then you could be in for a shock, literally...

The heater could be broken & shorted out (not unheard of), if that's so, putting power to it could result in bad things happening...


Post# 166738 , Reply# 6   1/22/2012 at 19:23 (2,999 days old) by Vacuumfreeeke ()        

Thanks guys.... it started working right again after I left straight vinegar in it overnight.... I bought some pads on Amazon and they arrived so it's steam cleaning bliss now.

I made a video of it before the pads came and I was just completely surprised at how quickly it melted the mess away!


CLICK HERE TO GO TO Vacuumfreeeke's LINK


Post# 166762 , Reply# 7   1/23/2012 at 04:11 (2,999 days old) by gsheen (Cape Town South Africa)        

gsheen's profile picture
The company were I worked designed and built there own version of this unit, while I was not actively involved in that project I was asked to come and look at what happens when it goes wrong. Forget about damaging the unit or shocking yourself. What you have there is a miniature bomb, those boilers are normally made from cast-iron and can be fairly thick, when they explode you have enough force and shrapnel to rip apart the plastic housing and shred any thing in its path. Some were I have pictures of one that went boom during testing, the walls were embedded with pieces of the boiler. I will see if I can find them

Post# 166804 , Reply# 8   1/23/2012 at 13:26 (2,998 days old) by kenmore81 (Warwick, RI)        

kenmore81's profile picture

Im glad its working again Bobby =)





Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


automaticwasher.org home
Discuss-o-Mat Forums
Vintage Brochures, Service and Owners Manuals
Fun Vintage Washer Ephemera
See It Wash!
Video Downloads
Audio Downloads
Picture of the Day
Patent of the Day
Photos of our Collections
The Old Aberdeen Farm
Vintage Service Manuals
Vintage washer/dryer/dishwasher to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy