Thread Number: 35606  /  Tag: 80s/90s Vacuum Cleaners
Nice oreck power brush not running after restoration 😢
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 382503   12/11/2017 at 11:49 (223 days old) by Oldskoolguy (Chicago, Illinois)        

So yesterday I spent hours cleaning out an old oreck power brush (better known as the Kirby Vacuette) and restoring it to either give as a Christmas gift to a friend or sell on eBay. Upon opening the machine, i found the motor was dusty. I opened it up to clean out the casing. Only to find out that one of the carbon brushes was bad as it just flew out and the spring separated from the head. I was lucky to have a spare GS electric motor (it was from a dirt Devil that I had to part out because no one would buy it), so I put the carbon brushes back in the motor as they should go and reassembled the vacuum. but after turning it on, the motor seemed to sputter a bit before turning off! I tested it before taking it apart and it worked. Any ideas what I can do? Iím afraid I may have made a critical error in restoring it or that I may have broken the motor!




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


Vacuumland home
Discuss-o-Vac Forums
Vintage Brochures, Service and Owners Manuals
Today's Vacuum of the Day
Photos of our Collections
Vintage Vacuum Cleaner to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy