Thread Number: 35281  /  Tag: 80s/90s Vacuum Cleaners
Hoover convertible high performance making a weird noise
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 379655   10/13/2017 at 06:04 by Gj3476 (Dallas,TX)        

gj3476's profile picture
Hello convertible fans! I have a late 80's/early 90's Hoover convertible high performance that I got from eBay almost a year ago and when I got it, it worked pretty good till in December when I was using it it somehow made a weird lawn mower like noise and I was like "What!?",so I thought the belt broke and got caught on the fan but it wasn't it and I thought the fan might have got broken but I checked with a flashlight and it wasn't it either,so I don't know I haven't been using it for almost a year and I hope someone knows the problem because I have know idea.

  Photos...       <              >      Photo 1 of 2         View Full Size



Post# 379657 , Reply# 1   10/13/2017 at 06:22 by Firebirdman55 (Owensboro Kentucky)        

firebirdman55's profile picture
I have had several plastic base Hoover Convertibles that the plastic brushroll housing either wears or breaks altogether, allowing the brushroll to spin freely in the housing. I would check this first.

Post# 379676 , Reply# 2   10/13/2017 at 11:41 by Gj3476 (Dallas,TX)        

gj3476's profile picture
Well actually there's no belt on the brushroll now,the brushroll is all good,it's the motor,is there a way I can send you a short video of the vacuum running for a few seconds?

Post# 379747 , Reply# 3   10/14/2017 at 13:26 by Phaeton (Los Angeles)        

phaeton's profile picture
Hello,
You might check the carbon brushes as they can cause loss of power and sputtering. Remove them to check their condition and that they are not stuck in place.
Good luck,
Pete


Post# 379757 , Reply# 4   10/14/2017 at 15:39 by Gj3476 (Dallas,TX)        

gj3476's profile picture
Thank you, I knew it might have to do with the carbon brushes,I'll try that,but how?

Post# 379759 , Reply# 5   10/14/2017 at 16:08 by Phaeton (Los Angeles)        

phaeton's profile picture
Hello,
Yes I understand, and to be honest I do not remember how the hood is removed LOL. If it were the Classic Convertible of the 60's & 70's I could tell you in a flash. I know I removed that style of hood many times at the shop. I believe it has 2 phillips/cross screws on the bottom that need to be removed. A picture of the bottom would help my old brain remember or better yet a Vacuumland Member jumping in and telling how to remove the hood.
Sorry I was not able to help,
Pete




This post was last edited 10/14/2017 at 17:26
Post# 379766 , Reply# 6   10/14/2017 at 18:31 by TheSpiritOf76 (Historic Midtown Wichita Kansas. )        
Yes....

thespiritof76's profile picture

It is two Phillip head screws on either side if the base, kind of towards the front wheels. That's it, then the hood should lift off.  The motor lifts out when the 4 screws on the base of the motor are removed.

 

In a slightly off subject question...Is that your Kenmore Twinfan upright in your cover pic? I have never seen that model before, if it is, please post some good clear pics of that.


Post# 379771 , Reply# 7   10/14/2017 at 19:32 by KirbyClassicIII (Milwaukie, Oregon)        
Gj3476

kirbyclassiciii's profile picture
Gabriel,

There's one more clue: the impeller fan. Would it be broken (missing fins)?

~Ben


Post# 379783 , Reply# 8   10/14/2017 at 23:44 by Gj3476 (Dallas,TX)        

gj3476's profile picture
TheSpiritof76🇺🇸,actually that is a Hoover concept 2 power drive from around the early/mid 80's that I got at goodwill for $23.80 back in June, it works very good but the handvac on it makes a rattle noise and yes I will take some pics of the vacuum,thank you.

Post# 379784 , Reply# 9   10/14/2017 at 23:46 by Gj3476 (Dallas,TX)        

gj3476's profile picture
If anyone would like,I can email y'all a short video of the vacuum,it's like a buzzing noise.

Post# 379786 , Reply# 10   10/15/2017 at 01:03 by KirbyClassicIII (Milwaukie, Oregon)        
Gj3476

kirbyclassiciii's profile picture
Gabriel,

I got the video you made... and I left you a reply saying it might be the fan!

~Ben


Post# 379804 , Reply# 11   10/15/2017 at 15:50 by TheSpiritOf76 (Historic Midtown Wichita Kansas. )        
No Gabe....

thespiritof76's profile picture

This is what I am talking about.


  View Full Size
Post# 379810 , Reply# 12   10/15/2017 at 18:25 by Gj3476 (Dallas,TX)        

gj3476's profile picture
Oh that yes it is an old kenmore and probably a twin fan model but I don't have that vacuum in my collection,that came from a goodwill store that I took a year ago,I should've gotten it.




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


Vacuumland home
Discuss-o-Vac Forums
Vintage Brochures, Service and Owners Manuals
Today's Vacuum of the Day
Photos of our Collections
Vintage Vacuum Cleaner to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy