Thread Number: 35198  /  Tag: Recent Vacuum Cleaners from past 20 years
Need help on sanitaire vacuum
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 379069   9/30/2017 at 21:26 by Evilvacuumman (Los Angeles)        

evilvacuumman's profile picture
Can anyone please help me with this. I think it might have to do something with the carbon brushes or the commutator. When I take the carbon brushes out and spin the motor I don't hear the noise but when I put them back in and spin it it makes the noise. They are brand new carbon brushes and are properly adjusted too. Please tell me.

CLICK HERE TO GO TO Evilvacuumman's LINK





Post# 379072 , Reply# 1   9/30/2017 at 23:05 by repairman (Stickney, IL)        

Try removing the bearing seal from the top and grease the bearing. I had a Sanitaire that made this noise until I serviced the top bearing.

Post# 379091 , Reply# 2   10/1/2017 at 10:56 by Evilvacuumman (Los Angeles)        

evilvacuumman's profile picture
I will try that. Thanks

Post# 379112 , Reply# 3   10/1/2017 at 19:42 by Evilvacuumman (Los Angeles)        

evilvacuumman's profile picture
I tried it and it still makes the same noise




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


Vacuumland home
Discuss-o-Vac Forums
Vintage Brochures, Service and Owners Manuals
Today's Vacuum of the Day
Photos of our Collections
Vintage Vacuum Cleaner to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy