Thread Number: 34459  /  Tag: Recent Vacuum Cleaners from past 20 years
Electrolux Epic 6500 SR
[Down to Last]

Vacuumland's exclusive eBay Watch:
scroll >>> for more items
Post# 372720   5/26/2017 at 17:10 by luxkid1980 (Richmond, Virginia)        

I came across an Electrolux Epic 6500 SR canister today with power nozzle and electric hose. For some reason the vacuum will not run with the hose attached. When I attempt to connect the hose, it stops and some things light up on the top. See picture. Im not sure what that second illuminated button means. Also, if I turn it on without the hose attached and place my hand over the opening where the hose attaches to the canister,it stops. Almost like it thinks there is a blockage. Is it supposed to do this? Thanks!

  View Full Size



Post# 372722 , Reply# 1   5/26/2017 at 18:49 by Luxkid1980 (Richmond, Virginia)        

I figured out it was the automatic control module so I disconnected the hose to the bag change indicator and it works now




Forum Index:       Other Forums:                      



Comes to the Rescue!

Woops, Time to Check the Bag!!!
Either you need to change your vacuum bag or you forgot to LOG-IN?

Discuss-O-MAT Log-In



New Members
Click Here To Sign Up.



                     


Vacuumland home
Discuss-o-Vac Forums
Vintage Brochures, Service and Owners Manuals
Today's Vacuum of the Day
Photos of our Collections
Vintage Vacuum Cleaner to sell?
Technical/service questions?
Looking for Parts?
Website related questions?
Digital Millennium Copyright Act Policy
Our Privacy Policy